Follow steps below to install the app.

Progressive Web Apps (PWA) are a relatively new technology and we are aware of issues with notifications.

We recommend installing the app from the Google Play Store or the Apple App Store for the time being.

Alternatively update your device to the most recent version.
Apple mobile devices must be IOS 16.4 or later.